Tag Archives: Virtualization

Cannot boot ubuntu VMs after kernel update

Two posts in one day.  I think there are pigs flying by my windows.  After running the updates on my freshly installed 10.10 server VM XenServer was no longer able to parse the grub file.  The message was strangely familiar … Continue reading

Posted in XenServer | Tagged , , , | Leave a comment

Error from bootloader: too many bootable disks

While checking something for a co-worker I ran into an issue recently reported in one of my comments.  Seems that it is possible to not be able to boot a PV ubuntu VM with an ISO mounted.  This is because … Continue reading

Posted in XenServer | Tagged , , , | Leave a comment

Adding your own certificate to the XenClient Synchronizer

The Synchronizer for XenClient comes with its own certificate.  However most final installations will want to have their organization’s signed certificate so it is trusted automatically.  My lab environment is very simple.  There is a root CA and no intermediate CAs.  … Continue reading

Posted in XenClient | Tagged , , , , , | Leave a comment

ubuntu 10.10 server on XenServer 5.6 FP1 beta

Well XenServer 5.6 FP1 beta is out.  I decided to finally see what tickets I entered during the 5.6 beta for ubuntu support were added.  Turns out they all were!  However there is at least one new patch needed.

Posted in XenServer | Tagged , , , | 8 Comments

Fix for Provisioning Server bnns.sys stop error

Back when beta testing XenServer 5.6 I reported a stop error trying to run XenConvert on an XP box for PVS 5.1.  The short answer was it was not supported.  Take a guess at what happened next…

Posted in XenDesktop | Tagged , , , , | Leave a comment

xe-edit-bootloader, Found 2 for VM, but only 1 is allowed.

This may come up following my two ubuntu on XenServer guides.  I figured I would explain what is happening and how to fix the error “Found 2 for VM, but only 1 is allowed” error from xe-edit-bootloader.

Posted in Virtualization, XenServer | Tagged , , | 3 Comments

ubuntu 10.04 beta server DomU on XenServer 5.6 beta

I’m one that always likes to test out the latest and greatest.  As frustrating as it can sometimes be, I do enjoy it.  So once I had ubuntu 9.10 server up on XenServer, I wanted to try ubuntu 10.04 server … Continue reading

Posted in Virtualization, XenServer | Tagged , , | 6 Comments

ubuntu 9.10 server DomU on XenServer 5.6 beta

I’ve been trying to get ubuntu up an running as a DomU in PV mode under XenServer for a while.  The Citrix blog article is horribly old and some info is no longer accurate.  There are a few key things … Continue reading

Posted in Virtualization, XenServer | Tagged , , | 7 Comments